Eredmény: 1 - 7 (7) összesen

Téma: Pixhawk PX4 / Ardupilot

  1. #1
    Junior Member
    Csatlakozott
    17-02-05
    Hozzászólás
    4

    Pixhawk PX4 / Ardupilot

    Sziasztok,

    Ha jól láttam, még nincs ilyen topic, szóval megpróbálok indítani egyet...

    A konkrét probléma amivel már napok óta kinlódok, az a "fligh mode change failed" üzenet, amit fura módon nem a fligh mode váltásra, hanem az arm kapcsolóra kapok. A státusz led zölden villog, a safety switch átkapcsolja a safety ledet folyamatos zöldbe, az ESC-k visszajeleznek, hogy megkapták az alap PWM jelet. EKF, GPS, stb ok, semmilyen hibaüzenet nem jön, csak nem lehet élesíteni.
    A neten semmilyen értelmes magyarázatot nem találtam - a hasonló hibák már élesített rendszeren jöttek elő. Ez a rendszer kb. két éve már repült, most új ESC-ket kapott, de más változás (szándékosan) nem történt. Arra emlékszem, hogy régen is nehezen élesedett, de akkor a GPS miatt kellett várni 1-2 percet, most több óra után sincs változás.

    A setup:
    Pixhawk PX4 2.4.8, V4.0.0 FW, octo + frsky8 receiver + neo 8 GPS. (semmi extra)

    Amit próbáltam:
    - letiltottam az összes pre-arm check-et.
    - végigpróbáltam az összes repülési módot (a loiternél a státusz sárgára vált)
    - újrakalibráltam, többször is.
    - próbáltam mission plannerrel és Qgroundcontrollal is.
    - megpróbáltam a beta 4.0.1RC-t FW-t , feltenni, de a letöltés elhasalt http hibával (és nincs is a release notesban semmi hasonló javítás)

    Mit nézhettem be?

    Köszönöm előre is!

    S.

  2. #2
    Senior Member smith_hun logója
    Csatlakozott
    14-01-16
    Hely
    Pécs
    Telefon
    06-húsz-négy négy 42 - nulla 52
    Hozzászólás
    2.842
    Halihó! Biztosan valahol jól el van dugva a hiba...anno (igaz repülőnél) én is csak kínlódtam az arm/disarm dologgal, így az az első, hogy ezt kikapcsolom, és szimpla gáz tiltás kapcsolóval biztosítom a gépet...
    Elsőre valahol a paraméterek között nézném meg, hogy az arm feltételeknél nincs-e olyan lehetőség, hogy milyen módban kell lennie armoláskor...repcsinél szokták javasolni a manual módot...így amikor véletlenül a kapcsoló armol, de nem manual-ban van, a gép akkor sem élesedik be...

    Az új ESC-k gáztanítása megtörtént?
    Melyik firmware van fenn arducopter, vagy px4?
    Ki tudod teljesen kapcsolni az arm-ot: arming_require 0
    Élesítés előtti ellenőrzés paramétere: arming_check 0

    Végső esetben firmware tennék újra, újra beállítanám, és miután minden klappol, lementém file-ba a teljes paraméter listát...

  3. #3
    Junior Member
    Csatlakozott
    17-02-05
    Hozzászólás
    4
    Szia,

    Köszi a gyors választ :-)

    Az ESC-k (blheli) frissek, és azonos beállítással vannak - szinkronban a távirányítóval.
    A firmware kicsit zavaros, mert már ebből is van fork, de ha jól néztem arducopter (meg chibios)

    Az arming require paramétert megtaláltam, letiltottam. Ettől a safety led rögtön folyamatosan világít, de a státusz továbbra is disarmed és a hiba is azonos fligh mode váltáskor.
    Feltettem a 4.0.1RC2-es és a 3.6.11-es FW-t is, a hiba azonos.

    Nekem sincs további ötletem, csinálok rajta egy törlést, és elölről kezdem. Csak azért szomorú, mert minden repülés előtt fél napot keresztül elölről kell kezdeni mindent?

    -OFF-
    Váltanék, de mire? Az összes töbi FW is össze-vissza támogat repülés vezérlőket meg hardvereket, és mind mást tud, nulla átfedéssel. Ráadásul némelyiknél hetekig tart, míg egyáltalán repülésre lehet bírni.

    Lehet hogy velem van a gond, de valahogy kezd az egész ardcopter (is, mint ahogy sok más projekt is) félecsúszni - elsikkadt a lényeg... APM 2.5-nél régebben nem volt ilyen gond, beállítottam, és jól-rosszul, de repült, lényegében alap beállításokkal is.
    Itt néha napokig kinlódik az ember, kalibrálással, meg hülye hibákkal, és a végén repülhetetlen az egész. Próbálom követni a leírásokat, de képtelenség, mert néhol 5-10 éves leírások vannak már nem létező softwarekkel, menükkel, opciókkal...
    Lassan akkora flash van a gépekben, hogy a háború és béke is beleférne, de összesen tud 10-20 hibaüzenetet, és még egy hülye kódot sem képes adni.
    Cserébe legalább semmilyen új hardvert nem támogat az utóbbi 10 évből: Létezik már fillérekért 2d lidar és ilyenek, de csak az ősrégi kódot tologatják ide-oda, minden látható eredmény nélkül. Új repülés vezérlő persze van, 160-200 ezerért, amin futtathatom ugyanazt a hulladék kódot.... :-(

    Bocs...

    -OFF-off- :-)

  4. #4
    Junior Member
    Csatlakozott
    17-02-05
    Hozzászólás
    4
    Sikerült megtalálni a hibákat, tegnap már élesíteni lehetett a drone-t - leírom a megoldást, hátha más is belefut....

    Nekem konkrétan a táp feszültséggel és akku érzékelővel volt probléma, de szerintem ez máshol is segítség lehet.

    Ezt a firmwaret tettem fel: https://github.com/PX4
    Elvben telepíthető customként a mission plannerből, vagy a Qgroundcontrol alapból felajánlja.

    Összehasonlíthatatlanul jobb hibaüzenetei vannak, töredék idő alatt töltödnek be a mavlink adatok - cserébe sajnos az i2c oled kijelzőtől nem látja a gps compasst, illetve pár dolog nem jól működik a mission plannerben (fligh mode, compass). Tehát marad a Qgroundcontrol és a kevesebb info.

    S.

  5. #5
    Senior Member smith_hun logója
    Csatlakozott
    14-01-16
    Hely
    Pécs
    Telefon
    06-húsz-négy négy 42 - nulla 52
    Hozzászólás
    2.842
    A tápfeszültség, és akkuérzékelő probléma mit takar? Elképzelhető, hogy be volt kapcsolva az a paraméter, amivel X Volt feszültség alatt nem lehet élesíteni a gépet? Vagy az árammérés nem volt megfelelően kalibrálva? Leírnád pontosan, mert így elég tág fogalom a hiba oka...A tápfeszültséggel, és az árammérővel nem szokott gond lenni, ha jól van beállítva...

    Nekem repülőnél akkor volt gondom az akkufeszültség csoporttal, amikor be volt kapcsolva a battery failsafe opció is, és az első repüléskor (berepülésen) beesett a feszültség, és élesedett a battery failsafe, a gép meg elindult vissza a Home Point-ra egy fordulózás közben...első ijedtségemben be is szartam...

  6. #6
    Junior Member
    Csatlakozott
    17-02-05
    Hozzászólás
    4
    Mivel opto-s ESC-ket kapott, szereltem rá két külön BEC-et, hogy hibatűrő legyen. Ezt jól be is kötöttem PX4 ESC kiemeteihez. Csakhogy A pixhawk PX4-nek két külön táp köre van, és így maga a vezérlő +gps + receiver csak az usb-ről kapott tápot, kemény 4-4.3 V-ot.
    Másrészt megpróbáltam kispórolni a gyári powermodult, (gondoltam nem pontos, mert mind a négy akksit úgysem vezethetem át rajta) pedig azon van BEC és akku érzékelő is.

    Bekötöttem mindent jó helyre, és megnyugodott a lelke - csak nem tudom, hogy az arducopter FW miért nem tudta ugyanezt a hibát adni. Valamint miért nem élesedik, ha kikapcsolom a pream check-et. Jó funkció ez a prearm check, de utálom, amikor felülbírál :-) Hadd tudjam már, hogy mit csinálok, ez ez egész pixhawk cucc úgy sem "vénnek való vidék" :-)

    Sajna ez a PX4 FW jó pár dolgot nem tud, szóval mehetek vissza arducopter FW-re, szerencsére megvannak az elmentett beállítások...

  7. #7
    Senior Member smith_hun logója
    Csatlakozott
    14-01-16
    Hely
    Pécs
    Telefon
    06-húsz-négy négy 42 - nulla 52
    Hozzászólás
    2.842
    Nálam a repcsiben dupla-redundáns (négyszeres) tápellátás volt, igaz én nem OPTO ESC-t használtam.
    1. kör: a gyári power modul,
    2. kör: ESC tápja a Servo3-on,
    3. kör: UBEC a Servo9-en,
    4. kör: ImmersionRC VTx tápja a MinimOSD telemetria vezetékén keresztül.

    A gyári PM viszonylag pontosan mér, ha a leírás szerint kalibrálod a fogyasztást. APM-Pixhawk-F4 esetében mindig van egy fix érték, amit meg kell adni, hogy 1V eséssel mennyi ampert lehet kivenni az akkuból (vagy mi), ha ezt az értéket viszonylag pontosan beírod, vagy eleve egy fogyasztásmérővel terhelés alatt megadod neki, hogy az észlelt áramfelvétel mennyi, akkor azután pontos a fogyasztás mérése.

    Én úgy tudom, hogy a PM mindenképp kell a Pixhawk-hoz, mert az összes hardver onnan kapja a tápot (GPS, I2C cuccok, telemetria, OSD, soros port, stb.)...USB-ről csak az alap érzékelők működnek...

    Hááát...igen. A Pixhawk már csak ilyen...Örülök, ha megoldódott...jó reptetést!

Hozzászólás szabályai

  • Új témákat nem hozhatsz létre
  • Válaszokat nem küldhetsz
  • Fájlokat nem csatolhatsz
  • A hozzászólásaidat nem módosíthatod
  •  
  • BB code : engedélyezve
  • Pofik engedélyezve
  • Az [IMG] kód engedélyezve
  • [VIDEO] code is engedélyezve
  • A HTML kód kikapcsolva